My AM deaf D201

This area is dedicated to talk about tube radios, or amplifiers.
User avatar
Blue Ox2
Donor
Donor
Posts: 702
Joined: March 27th, 2017, 5:17 pm
Age: 69
5

#401815

Post by Blue Ox2 »

Well, Barkett doesn't seem to want to work on a complete refurbish
at this time.

Guess I would be willing to just get a good repair and have the thing working, lol.

Still praying for the positive outcome of this issue.

73 fer now,

Mike aka PA223







**************
How do you do from Blue Ox2
KPA223 on the Galaxy DX 2517
American Eagle SSB Group * AE1582
The World Radio Club * 2WR1582
Lititz, PA (2013 "Coolest Small Town in America")


**************

Donate to CBRT
User avatar
Hefalcon
NEW DUCK
NEW DUCK
Posts: 0
Joined: March 13th, 2022, 4:20 pm
Age: 64

#408786

Post by Hefalcon »

Hi, Did you ever solve your Tram D201 issue ? asking because I have the exact same issue. I read someplace that the relay can cause this issue but have not been able to locate a replacement. I did the same as you, recapped and replaced all the 2 and 3 watt resistors. Tubes are all good!.







Donate to CBRT
User avatar
warlock35po
Duckplucker
Duckplucker
Posts: 134
Joined: February 10th, 2010, 1:19 pm
Age: 73
12

#408793

Post by warlock35po »

Hello,B C,D did you get the tram working? if so where did you send it.I have a D201 A.that has issues from being dropped so I need some one who really specializes in the old Beasts.I wild rally appreciate if you could help Regards warlock35po







Donate to CBRT
Post Reply Previous topicNext topic